Can't log in with my account and password

I created a new IDC account, but won’t let me log in. I also tried reset the password, still am not able to log in with a reset password.

@Linmin_Pei can you please clarify if you logged in via existing Google account, or created a new IDC account?

@fedorov I can’t log in with existing Google account, but I believe I also created the IDC account with my GMail email address. None of them works.

@Linmin_Pei After clicking on the “Sign In” link in the upper right, you see this screen:

If you have a Google ID, you would click on the Blue Rectangle “Sign in With Google”, which would take you to a standard Google sign in page where you enter that Google ID and your Google account password.

If you have a local IDC account (no Google ID required), then you enter that plus your password in the lower set of boxes. To go that that route, you need to do the account “Sign Up” process and get the local account set up.

If you have a Google ID, that method is easier, and as long as e.g. Gmail is working in your browser, you should be good to go using the top Google sign in button.

What methods have you tried to use? If you have gone the Google ID route at the top, and are providing your Google ID and Google password, what problems are you having?


@Linmin_Pei I need to emphasize that the top blue Sign In With Google button only works with your Google ID and the password you have set up for Google. The bottom sign in only works for the local IDC account and password. You can’t use your Google ID and Google account password in the lower sign in.

Having just run through the process myself (working with the local account, not the Google account), it can be easy to mix up which email address you are linking to the password. When entering the new password, it is not showing you which email address it is associated with. If you are working with two different email addresses, it can get a little bit confusing.

@Linmin_Pei There is a password lockout mechanism in the system to comply with NIH security requirements. It disables login after a number of attempts in a short time period. We are working to reset that for your IP addresses. Did you encounter that in your login attempts?

Sorry replying very late. It works now. Thank you. @wlongabaugh, @fedorov