Unable to install Slicer IDCBrowser extension

I’m trying to install the IDC module to slicer, but I get the following error:

It appears that the IDC module was updated over the weekend, so I suspect something broke it.

Amanda, there are no failures in packaging the extension for any of the three platforms (you can see this if you follow the dashboard link from the extension github page - “golden packages” icons indicate the extension packaging was successful).

Did you try Preview or Stable? On what operating system?

I’ve just tried Preview on Mac, and everything worked fine.

It might have been an intermittent network issue. You could retry (you may need to uninstall the extension first, if it appears as installed).

I’m confused, I did check the dashboard, and it also says the releases are not working properly. This is the dashboard I’m seeing:

And I’m still getting the install error.

I’m on a mac, and I don’t know whether I’m in preview or stable, there is only one option for install in the extensions manager for slicer.

Amanda, sorry about that - I understand your confusion!

What the dashboard is saying with that “Test Fail” column is that there is a failing test. Failing test does not prevent the package from being generated, since “Configure” and “Build” stages were successful.

That specific failing test is meaningless, it is a leftover from earlier development, and does not indicate a real problem with the extension. I should definitely fix it, but we have been busy with tasks that I assigned higher priority.

You can get the version of 3D Slicer application from the menu, as shown in the screencapture below.

2024-05-31_11-05-32

Can you please try deleting the Slicer application (just go to mac “Applications” folder and delete the Slicer app), and install stable release? To install stable release, go to https://download.slicer.org/ and click the button shown by red arrow below.

Very important (and not intuitive perhaps, since this is known to be confusing to the beginner users) is that after opening the package .dmg you need to install the application by dragging the Slicer.app icon to your Applications folder, as shown below!

If after installing the stable release as discussed above you are still having problems, please check if you have any firewall protection, VPN, or anything else that may interfere with accessing external servers.

Hope this helps - looking forward to your response!

@ACharbonneau can you please let us know if you are still experiencing this problem, or if the issue is resolved?